Jump to content


25 model T "hay penny"


  • You cannot reply to this topic
4 replies to this topic

#1 blueoval92

blueoval92

    MCM Friend

  • Members
  • PipPipPipPip
  • 210 posts
  • Location:Louisiana
  • Full Name:jonathan delhommer

Posted 31 October 2012 - 12:19 PM

well its been a while since ive been able to get to my bench, and sadly i have loss some interest in my current builds so hoping to renew that interest i caught a idea while walking around in pepboy's today. I came across duplicolors copper plate system and decided to try it on the AMT 1925 model t 3 in 1 kit i picked up at my local hobby shop. plan to basically do a out of box build. the goal is to K.I.S.S. and just make a clean build.

Doing the spoon test right now to see how the copper plate system will work then i will start priming pieces later tonight hopefully. if this doesnt work i guess ill be ordering some BMF copper sheets.

#2 Ace-Garageguy

Ace-Garageguy

    MCM Ohana

  • Members
  • PipPipPipPipPipPip
  • 6,399 posts
  • Location:Down two, then left.
  • Full Name:Bill Engwer

Posted 31 October 2012 - 04:22 PM

I will really be looking forward to see what you do with this magic copper plate system.....very interesting.

#3 blueoval92

blueoval92

    MCM Friend

  • Members
  • PipPipPipPip
  • 210 posts
  • Location:Louisiana
  • Full Name:jonathan delhommer

Posted 01 November 2012 - 01:53 PM

got the parts all primed and started stripping a few chrome parts. engine halves glued and intake is painted, should have the frame and rest of engine parts painted tonight and get the firewall glued to the body. may even paint some interior if i have time.

for some reason my computer changed the format of my pics and i cant upload them. will work on it and post some pics if i am able.

#4 blueoval92

blueoval92

    MCM Friend

  • Members
  • PipPipPipPip
  • 210 posts
  • Location:Louisiana
  • Full Name:jonathan delhommer

Posted 02 November 2012 - 03:12 PM

so still no luck with pics, wish i knew why. I got the frame painted, couple engine parts painted, and have started spraying on the copper, kinda tricky to get to lay down even, i guess its the kind of paint. but 1st coat is looking good, about 4 more to get it to the shade i want.

#5 blueoval92

blueoval92

    MCM Friend

  • Members
  • PipPipPipPip
  • 210 posts
  • Location:Louisiana
  • Full Name:jonathan delhommer

Posted 02 November 2012 - 04:17 PM

so im very displeased with alclad 2 microfill primer. decided to try some alclad i bought a while back and wanted to use their primer, it clogged my airbrush and what did spray out before the clog was not very good, it dried almost as fast as it came out and was like a powder on the parts that just rubbed right off. I know my brush was clean because i cleaned it a couple hours ago very thoroughly, i think i will stick to my normal primer instead.

got the body and floor pan painted with the copper plate system, im pretty pleased with the results. its not even but gives more of a kinda weathered look, will try taking pics with a different camera and try to post them later. it really is something to see, its a way different copper than anything i have seen from testors or model master or tamiya.