Jump to content


Revell 1969 COPO Camaro ZL-1 - Hugger Orange - Post Fixed


  • You cannot reply to this topic
29 replies to this topic

#21 RandyB.

RandyB.

    MCM Avid Poster

  • Members
  • PipPipPipPipPip
  • 421 posts
  • Location:Ontario Canada
  • Full Name:Randy Bodkin

Posted 30 July 2014 - 12:16 PM

Dang Randy , I can't even tell where the post was broken, ifyou wouldn't have said any thing and posted these pics no one would have known ......GREAT build !!!!

 

Thanks Roger and Ron. Things like that really bug me and I just couldn't leave it that way. Feeling better now.   :)



#22 DynoMight

DynoMight

    MCM Ohana

  • Members
  • PipPipPipPipPipPip
  • 1,326 posts
  • Location:Wadsworth, OH
  • Full Name:Glenn Might

Posted 30 July 2014 - 12:18 PM

The post looks a lot better, great job.



#23 midnightprowler

midnightprowler

    MCM Ohana

  • Members
  • PipPipPipPipPipPip
  • 7,945 posts
  • Location:East Bethel, Minnesota
  • Full Name:Lee

Posted 30 July 2014 - 01:20 PM

Nice save.

#24 mikemopar70

mikemopar70

    MCM Avid Poster

  • Members
  • PipPipPipPipPip
  • 451 posts
  • Location:Quebec, Canada
  • Full Name:Michel Paquette

Posted 30 July 2014 - 03:45 PM

Wow!

Your Camaro is really nice, i built this kit last month and i can say it is still a very good kit.. 

 

I like this color on the Camaro, it looks natural..

 

Good job, nevermind that broken post, i can't see it anymore!!


Edited by mikemopar70, 30 July 2014 - 03:48 PM.


#25 PappyD340

PappyD340

    MCM Ohana

  • Members
  • PipPipPipPipPipPip
  • 5,159 posts
  • Location:High Point, NC
  • Full Name:Larry Dailey

Posted 30 July 2014 - 04:10 PM

Very NICE job Randy, bummer on the broken post but stuff does happen unfortunately!!   :) 



#26 mangodart

mangodart

    MCM Avid Poster

  • Members
  • PipPipPipPipPip
  • 481 posts
  • Location:France
  • Full Name:emmanuel Alleaume

Posted 30 July 2014 - 08:55 PM

Very nice build, you did well repairing the broken post  ;)



#27 mikemodeler

mikemodeler

    MCM Ohana

  • Members
  • PipPipPipPipPipPip
  • 3,204 posts
  • Location:NASCAR Country!
  • Full Name:Classified

Posted 31 July 2014 - 04:34 AM

Looks very nice, I have several of those first gen Camaros painted Hugger Orange, can't help myself !



#28 Johnny1973

Johnny1973

    MCM Ohana

  • Members
  • PipPipPipPipPipPip
  • 939 posts
  • Location:Port Charlotte Florida (Formerly of Passaic New Jersey)
  • Full Name:John Hines III

Posted 31 July 2014 - 10:14 AM

Very nice Camaro,nice job on fixing the post



#29 RandyB.

RandyB.

    MCM Avid Poster

  • Members
  • PipPipPipPipPip
  • 421 posts
  • Location:Ontario Canada
  • Full Name:Randy Bodkin

Posted 31 July 2014 - 12:46 PM

Thanks guys!



#30 Harry P.

Harry P.

    MCM Ohana

  • Administrators
  • PipPipPipPipPipPip
  • 23,560 posts
  • Location:NW suburban Chicago
  • Full Name:A mere layman...

Posted 31 July 2014 - 12:57 PM

What fit issues did you have?what could have caused the snapped pillar?I built the kit and everything fit perfectly!  2007_0903Spock0424.jpg

 

Except the windshield, apparently...