Jump to content


uniongoon

Member Since 03 Feb 2008
Offline Last Active Jul 20 2008 05:48 PM
-----

Topics I've Started

Finished the first

27 April 2008 - 05:45 PM

Took a long time, but I only worked on it when I was in the mood. Had some decal hiccups, and the tire decals did not work at all. But overall, I am pleased with my first effort. Next is an Avro Arrow.
Posted Image
Posted Image
Posted Image
Posted Image

Yamaha 50th Anniv.

22 March 2008 - 06:27 PM

Well, my first bike model, and also first model since I was a young kid.
First attempt I tried too many colours, silver, copper, clear red, clear blue and blue. Started out good and then got too dark with excess paint. So I stripped it and started again, stripping it actually gave it a weathered look sort of like my old ZX11 in my garage.
1st coat Testor's silver
Posted Image
2nd, light dusting of Tamiya titanium gold
Posted Image
Then some accents with Tamiya clear blue
Posted Image
mounted
Posted Image
and the other side, showing my decal damage on the yellow/black, ouch
Posted Image

Yamaha 50th Anniv.

05 March 2008 - 03:43 PM

I am 44 yrs old, new to the site. My son builds alot of trucks, I ride bikes, and am trying to get through a long hard winter. I have not touched a model since I was about 13 and decided to give it a shot, here is my start.
Posted Image

First time with an air brush too. Clear coat did not flow too well, should I be thinning it? I am using Tamiya paint products.

Here is my full size bike
Posted Image