Jump to content
Model Cars Magazine Forum
Mike77

B.R.B.O. Kenworth W900L...7/17 update...with color!

Recommended Posts

Hey guys, my KW has suffered irreversible damage to the cab/sleeper so I have to pull out of the contest. I'll use the chassis and fenders for something else eventually. I hate to have come this far only to have to sit on the sidelines but there's nothing I can do.

Best of luck to the remaining contestants. Hopefully there's another contest next year with better results for me! :lol:

Share this post


Link to post
Share on other sites

 

 

The clear coat had a reaction with the paint. So I tried the oven cleaner stripper thing I've heard so much about. That had a reaction with the clear coat, the paint, the primer, and the body filler. Then I had a reaction to the whole thing.  banghead.gif

Share this post


Link to post
Share on other sites

Paint problems, man I hear that!

Sorry Mike to hear about this, lots of work trying to get the situation back to normal, good luck to you.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...