Jump to content
Model Cars Magazine Forum
Sign in to follow this  
oPROJECTMAYHEMo

Help fixing damaged chrome!!!

Recommended Posts

Hi Guys,

I am building an SS Chevelle and had to use masking tape on the rear bumper as there is small amount that requires painting the same color as the car.

I never weakened the adhesion of the tape before applying it and now I have removed it I can see it has taken some of the chrome with it. Not a massive amount but enough to P**S me off.

Anyone know how to fix this effectively?

Thank you

Share this post


Link to post
Share on other sites

Without pictures we have to guess, but Molotow chrome pens have pretty much taken over this job.

Share this post


Link to post
Share on other sites
3 hours ago, oPROJECTMAYHEMo said:

Hi Guys,

I am building an SS Chevelle and had to use masking tape on the rear bumper as there is small amount that requires painting the same color as the car.

I never weakened the adhesion of the tape before applying it and now I have removed it I can see it has taken some of the chrome with it. Not a massive amount but enough to P**S me off.

Anyone know how to fix this effectively?

Thank yo

As Mike has already said, without a photo it's hard to recommend a fix, but Revell Germany got a lot wrong on the instructions, the parts that they call out to be painted body colour should be black,there's 2 decals on the decal sheet that you should use for this.

 

 

200430_Rear_3-4_Web.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...