Jump to content
Model Cars Magazine Forum

Ads displaying over topics


jaymcminn
 Share

Recommended Posts

I have NEVER seen an ad on this forum the 2 years I have been here. It may be because my son installed a popup blocker on my PC. It works fantastic apparently. I just looked and it has saved me from 491,272 popup ads since it was installed.

Edited by Bills72sj
additional info
Link to comment
Share on other sites

  • 3 weeks later...

There are several issues. First not all browsers behave exactly the same. Second is not only are  standard computers being  supported but also mobile devices. The result is a one size fits all solution that doesn't always behave. Another factor is when changes are also introduced another layer of problems can creep in.

Definitely an annoying situation.

Link to comment
Share on other sites

One thing that might be helpful is when you have this problem would be to indicate the device type mobile or laptop/desktop, mac or windows, and what browser is being used. This might help Dave with getting help from the site provider.

Link to comment
Share on other sites

It appears to be Google behind the ads that I have X'd out of. It is one thing when are appearing between posts but really darned annoying when they obliterate posts.

They all come through the MCM Forum server so why can they not be blocked on the server with a pop up blocker?

Link to comment
Share on other sites

1 hour ago, Redisetta said:

Come on guys , you really need to do something about this , I don’t see this on other sites 

 

The problem is that we need the ads for revenue to keep this site free. I guess we could start an option where we charge folks $25 a year for ad free site.

The problem is really the ad companies, they get paid to put their customer's ads in front of people. They continually cheat/change the system for displaying ads.

It is an ongoing battle to reconfigure the site to get the ads to display properly, but then 3 days later the ad companies change the coding in the ads and they start taking over again.

Everyone has the option to install an ad blocker on their computer to stop displaying ads. The downside is it takes operating revenue away from the board.

This is an active site that has been around for a while. There is a lot of information that is stored and server space has costs associated with it.

There are other ad systems out there and I know the ownership of the board has been looking into them.

Whenever someone is inconvenienced by an ad or its placement and points it out here, I tag the post so that Dave knows the ad companies have changed their strategies again.

He is usually already on it and just trying to find a free hour or two to address it. Keeping this site up and running has become his 3rd job.

 

FYI - I do not run an ad blocker for this site and have never seen the full page ads you guys post about. This could also be a combination of settings on your device and/or operating system.

  • Like 2
Link to comment
Share on other sites

On 1/18/2022 at 7:09 PM, bobthehobbyguy said:

One thing that might be helpful is when you have this problem would be to indicate the device type mobile or laptop/desktop, mac or windows, and what browser is being used. This might help Dave with getting help from the site provider.

This is important. Give Dave some information to invision so they can look into the problem.  

Second how many people are experiencing this problem.

Some of the google ads have an x which has a menu for why you don't want to see an ad. One of the options is the ad covers content so it isn't just a phenomenon of the site.

 

Link to comment
Share on other sites

@Mike C.    @Redisetta   @showrods  @Lunajammer

Are you all on mobile devices? (e.g. phone or tablet) I've seen it on desktop, but only rarely. 

 

This looks to be some unholy interaction between our forum software and Google Ads. Our first step here will be to update to the current version of the forum software. I will get that scheduled forthwith. 

Link to comment
Share on other sites

1 hour ago, Dave Ambrose said:

@Mike C.    @Redisetta   @showrods  @Lunajammer

Are you all on mobile devices? (e.g. phone or tablet) I've seen it on desktop, but only rarely. 

 

This looks to be some unholy interaction between our forum software and Google Ads. Our first step here will be to update to the current version of the forum software. I will get that scheduled forthwith. 

I'm on a Mac...and I'm seeing those pop pads again after a short lull.

I can't speak for anyone else but give what you've said above, I wouldn't mind banner ads or ads down the side.

What advertisers don't seem to realize is that by circumventing things and creating ads that appear over content, they make the viewer annoyed at them and their products.  I'm not stopping to read a ad over content, I'm going to ignore it at all costs. 

Advertisers are doing more harm than good to themselves with these types of ads but they don't seem to realize it.

Edited by showrods
Link to comment
Share on other sites

2 hours ago, Dave Ambrose said:

Are you all on mobile devices?

Not on smart phone but on Mac laptop and Mac desktop and at different ip addresses.

Twice a square ad appeared small, then on another page or a few minutes later the same ad appears wall to wall and so over sized that it's blurry. I think my browsers are updated, but I'll have to check that (Chrome and Safari).

Edited by Lunajammer
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...