Jump to content
Model Cars Magazine Forum

29 Ford Roadster


Recommended Posts

Posted (edited)

Built one of these about 8 months ago, time for another one. The first one I built as the high boy, I'll do the channeled version this time.  All comments welcome and thanks for looking.

29 Ford Model A.png

Edited by bluestringer
  • Like 1
Link to comment
Share on other sites

6 hours ago, bluestringer said:

Built one of these about 8 months ago, time for another one. The first one I built as the high boy, I'll do the channeled version this time.  All comments welcome and thanks for looking.

29 Ford Model A.png

I also built a highboy version a few months back and will also be doing a channeled version to sit alongside it. Hopefully the windshield frame in the new kit will be better than the one that came with the last one. At least Revell sent me a replacement frame that got here from Germany only 6 days after asking for it.

  • Like 1
Link to comment
Share on other sites

18 hours ago, NYRich72 said:

I also built a highboy version a few months back and will also be doing a channeled version to sit alongside it. Hopefully the windshield frame in the new kit will be better than the one that came with the last one. At least Revell sent me a replacement frame that got here from Germany only 6 days after asking for it.

How did you go about getting the new windshield frame? I need one too 😩

  • Like 1
Link to comment
Share on other sites

The windshield frame in my first one was warped a little and I ordered a new one from Revell. It took a while to get it and I fixed the one I had so I have a new one. The one is this kit I'm working on now looks ok, I think it will be fine, but if not I have a replacement. I'm going with this Createx Yellow for the color this time. Haven't decided on the interior yet.

_IGP0916.jpg

Link to comment
Share on other sites

4 hours ago, customline said:

How did you go about getting the new windshield frame? I need one too 😩

I emailed Revell at....service@revell.ge

I told them what the problem was and supplied the kit and part numbers. They replied to my email in a couple of days and the part arrived 6 days later.

 

  • Like 1
Link to comment
Share on other sites

2 hours ago, bluestringer said:

Ok, engine is about ready. But what's up with this....with the rear peg on the crossmember in the hole on the trans, the motor mounts do not line up. What did I do wrong. I'm sure it's the correct frame and crossmember. 

_IGP0918.jpg

_IGP0922.jpg

_IGP0923.jpg

Heres the bottom of one of my 29's.  You have to make sure the engine is on the two mounts or things up front won't line up then check out what's going on either the tailshaft.

20220511_164616.jpg

Link to comment
Share on other sites

3 hours ago, bluestringer said:

Ok, engine is about ready. But what's up with this....with the rear peg on the crossmember in the hole on the trans, the motor mounts do not line up. What did I do wrong. I'm sure it's the correct frame and crossmember. 

Not sure what’s going on there? Mine lined up OK. That said….the yellow is really bright, it will look awesome when done! I like the yellow accents between the fins on the oil and tranny pans.👍

90045C24-89D1-422F-8B63-41C930BDC616.jpeg

Edited by NOBLNG
Link to comment
Share on other sites

2 hours ago, Zippi said:

Heres the bottom of one of my 29's.  You have to make sure the engine is on the two mounts or things up front won't line up then check out what's going on either the tailshaft.

20220511_164616.jpg

Yea, I've got to figure out what's going on, it's not going to work like this. I'll mock up the rear end and driveshaft to see if it's off. If I cut that pin off the crossmember and slide the engine into the mounts, then the shaft may be too short. Something ain't right. I didn't have this problem on the first one. 

Link to comment
Share on other sites

1 hour ago, NOBLNG said:

Not sure what’s going on there? Mine lined up OK. That said….the yellow is really bright, it will look awesome when done! I like the yellow accents between the fins on the oil and tranny pans.👍

90045C24-89D1-422F-8B63-41C930BDC616.jpeg

Thanks. On yours and Bob's the rear pan looks closer to the crossmember than on mine, I wonder if the hole for the pin is in the wrong spot. I'll try to find out what's going on tomorrow. 

Link to comment
Share on other sites

I doubled checked, and I'm using the frame that's numbered 77 and crossmember 141.  This is what I want because I'm building the B version. Here's something strange, I fitted the engine in the other frame and crossmember and it's fits fine.  I have my parts left over from my first build which I built the A version, so I grabbed the number 77 frame and 141 crossmember from that kit and the engine does not fit it either. I'm sure this kit only has the one engine block, so I don't know what's going on. I either have to put the engine in with the hole in the trans in the peg on the crossmember and leave the mounts as they are and hope every thing fits up front. If I put the engine into the mounts correctly I will have to do something to the rear crossmember because the pan hits it and I will have to shorten the driveshaft also. I'm getting frustrated with this B build, may just build another A with the tri-carb setup. 

  • Like 1
Link to comment
Share on other sites

On 5/11/2022 at 1:45 PM, NYRich72 said:

I emailed Revell at....service@revell.ge

I told them what the problem was and supplied the kit and part numbers. They replied to my email in a couple of days and the part arrived 6 days later.

 

Thank you, Richard, I tried to navigate the website but kept getting tangled up in 404s 

I can't make my email go out, Richard, is that address correct?

Nevermind, I got it straight! Windshield frame is on the way!

Edited by customline
More info
Link to comment
Share on other sites

2 hours ago, Zippi said:

You know how modeling works James.  If it doesn't fit, we make it fit.  You'll get it Buddy.

That's what I'm going to do. I'm going to install it as is.  I think the only problem I'll have at the front will be the rad hoses being too long, I can just snip them off. If I install the engine with the front mounts in correct position I'll have to do some work to the crossmember and shorten the driveshaft.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...