• Announcements

    • Forum Posts, Moderating, Reporting, etc.   12/20/2016

      The Report function of the forum works well. If you see someone acting up, acting out, or just being an okole, use the Report function. It works! I have it set up so it not only sends me an email, but that email is then marked with a flag, and get's put to the top of my email list. I will try to access/look at the report/topic as soon as possible, but remember, I'm on a six hour time delay, and other mods not only have a life, but a real job as well.  k den

Chevy titan engine mount issue

6 posts in this topic

Posted

Did anybody have mounting issues with the first crossmember, it looks like I will have to shave some off the bottom to make the engine fit, any ideas from you guys?

Share this post


Link to post
Share on other sites

Posted

Yup, always a fit issue.

Share this post


Link to post
Share on other sites

Posted

Yup, always a fit issue.

Yup, always a fit issue.

Thank you Tim I figured I would have to do that, thank you for the quick response

Share this post


Link to post
Share on other sites

Posted

Also, If u look close, it says to mount the engine to the bottom of the mounts on the frame. It fit perfect that way on mine!

Share this post


Link to post
Share on other sites

Posted

Charles I caught that, but I still had to shave a little off, thanks for the response!

Share this post


Link to post
Share on other sites

Posted

Anytime!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now