Sign in to follow this  
Followers 0

Vintage Drag Models Inc.

9 posts in this topic

Posted · Report post

Do any of you know anything about this forum ?

I registered on March 15th but still can't access the site , it says my account has to be activated by an admin .

The forum appears to be active as it shows todays date .

Share this post


Link to post
Share on other sites

Posted · Report post

Yep, the forum is active and alive. It took a while to get my account activated too, but still it didn't take that much time as yours! I don't know what might be the problem, maybe DragMaster hasn't got your account to be activated? I don't know?

Share this post


Link to post
Share on other sites

Posted · Report post

well worth the read

Share this post


Link to post
Share on other sites

Posted · Report post

Maybe one of you can help out and ask the DragMaster to let me in ! ! !

Share this post


Link to post
Share on other sites

Posted · Report post

I'm on there, took a couple of days to get confirmed.

Share this post


Link to post
Share on other sites

Posted · Report post

A couple of days or even a week I can understand , but it's been more than a month !

Share this post


Link to post
Share on other sites

Posted · Report post

I was a member for a year or so, then for some reason was banned, haven't been able to get in touch with anyone to find out why.

Share this post


Link to post
Share on other sites

Posted · Report post

I'm an active member. I gave Dragmaster a hedz up. Don't know why he dropped the ball... I'm guessing he should be contacting you very shortly.

Share this post


Link to post
Share on other sites

Posted · Report post

I appreciate the help Bernard but in 5 days it will have been TWO MONTHS ! I don't think I want to be a member anymore .

Share this post


Link to post
Share on other sites
This topic is now closed to further replies.
Sign in to follow this  
Followers 0