Jump to content
Model Cars Magazine Forum

Show me your Revell '69 "429" Corvettes


Monty
 Share

Recommended Posts

Ah yes, the "429" misprint on the box art certainly raised a few eyebrows Monty :D !

Must have been a Friday when the proof readers looked at this one ;)

Sorry mate, never built the thing...

Makes me wonder if anyone ever stuffed an actual 429, Boss or otherwise, into one of these kits just so it matched the box description. Better drop a Toploader in there too, while you're at it.

Link to comment
Share on other sites

Here's the one I built awhile back. As I remember, it went together without any problems. Nice kit.

Maybe it's just me, but it seems like metallic blue paint just rocks on the early C3 Corvettes. Nicely done, Paul.

Link to comment
Share on other sites

I recently finished this one, must say that it went together very nice and the detailling is pretty good for a what older Revell kit.

Erik, I must say I like they way you enhanced what Revell provided. One of the first things I noticed was the plug wire routing. The wires appear to be in correct firing order and run correctly down the back of the block.

Question: how did you get a part number stamped on the radiator hose?

Link to comment
Share on other sites

Erik, I must say I like they way you enhanced what Revell provided. One of the first things I noticed was the plug wire routing. The wires appear to be in correct firing order and run correctly down the back of the block.

Question: how did you get a part number stamped on the radiator hose?

Erik's model is excellent, but the plug wiring is incorrect. Street Corvettes, being clothed in fiberglass bodies, required shielded spark plug wiring to prevent severe radio interference. The large shiny shroud served that purpose and wiring was hidden around the distributor.

8361626002_81bdf94687_z.jpg

4021245940_d4564c2a57_z.jpg

1969_Corvette_L46.jpg

Link to comment
Share on other sites

Danno, in the 20 years that I had mine, I encountered any number of other owners who didn't have the shielding element either, but for whatever reason weren't having any problems with their radios. A quick look at Google Images "1969 Corvette engines" will confirm that a lot of those shields are no longer in use, which suggests there are workarounds (aftermarket radio/tape player?) of some sort, if necessary.

When I purchased my 'Vette, it didn't have the shielding either, and the radio continued to work fine, even with successively more powerful ignition systems. (Davis Unified Ignition stuff rocks, BTW).

I complimented Erik for his wiring because it looked good and also because he avoided two modeling cliches (for lack of a better word) that we used to see on this board all the time.

1) It wasn't just a bunch of wires jammed in a tube. He made the effort to replicate the look of a real setup.

2) It wasn't the "angry spider" look that used to be so common a couple years ago. Even without the factory shielding in place, the wiring still goes down the back of the block, into two restraint loops, and then up to the heads.

Lastly, judging by the custom paint and wheels, I'd say its doubtful that Erik's intention was to replicate a factory stock 'Vette in the first place.

Edited by Monty
Link to comment
Share on other sites

Those are some great looking corvettes gentlemen :)

I agree, and even though I had a red 1:1 Corvette, it's kinda nice seeing them in other colors (not that I'd object to anyone posting a red one.)

I should confess that I had an ulterior motive for this. In the original post, I specifically asked if anyone had had problems with this kit, and obviously nothing insurmountable has been mentioned. I asked this because an experienced, adult member of another modeling forum I'm on made a claim about a month ago that this kit was "unbuildable". He claims he'll have to break the chassis in half to get it in place where it can be glued together. No one has mentioned having to go to any such lenghts on here....hmmmmm.

Having seen how these guys' builds turned out, I need to get mine moved up on the to-do list.

Link to comment
Share on other sites

Danno, in the 20 years that I had mine, I encountered any number of other owners who didn't have the shielding element either, but for whatever reason weren't having any problems with their radios. A quick look at Google Images "1969 Corvette engines" will confirm that a lot of those shields are no longer in use, which suggests there are workarounds (aftermarket radio/tape player?) of some sort, if necessary.

When I purchased my 'Vette, it didn't have the shielding either, and the radio continued to work fine, even with successively more powerful ignition systems. (Davis Unified Ignition stuff rocks, BTW).

I complimented Erik for his wiring because it looked good and also because he avoided two modeling cliches (for lack of a better word) that we used to see on this board all the time.

1) It wasn't just a bunch of wires jammed in a tube. He made the effort to replicate the look of a real setup.

2) It wasn't the "angry spider" look that used to be so common a couple years ago. Even without the factory shielding in place, the wiring still goes down the back of the block, into two restraint loops, and then up to the heads.

Lastly, judging by the custom paint and wheels, I'd say its doubtful that Erik's intention was to replicate a factory stock 'Vette in the first place.

Well, we certainly agree that his 'Vette is a great looking model and his wiring is well done.

You make a good point regarding "Day 2+" . . . it's not a factory stock build, so more leeway should be given. I don't have any problem with agreeing with that. It's just not correct for a factory engine, if that's what was intended.

Link to comment
Share on other sites

Thanks guys, glad to hear you like the car. The intention wasn't co create a factory stock car, but mildly custom. I shaved the doors, omitted the running lights ( I basically do that on every car I work with, they are soooooo ugly) and a nice paintjob.

The kit is actually a California wheels and came with those wheels, but also with decals for the hoses. Which was a nice suprise and more kits should have them.

My origininal intent was to build with the chrome shroud, but when working on the engine, it just didn't look so good. there was too much chrome, so I cut it off the airfilter and as bonus I could show my wiring.

I didn't do the firing order exactly like it should be, but there is enough randomness in the criss-cross to make it look assumable.

Since it is a model, I am not that attached to strict-factory, I can add my own swing to it and that freedom for creativity is what I like in modelling :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...