Revell 1969 COPO Camaro ZL-1 - Hugger Orange - Post Fixed

30 posts in this topic

Posted (edited) · Report post

Just finished this kit but did encounter a few fit issues with it and ended up breaking the driver's side "A" post. Fixed it as best as possible but it does detract from the overall appearance slightly. Not much you can do about it as these things do happen from time to time. Anyway, have a look and see what you think and thanks for checking her out.

Revell1969COPOCamaroZL1a_zps5d61adec.jpg

Revell1969COPOCamaroZL1b_zpsbb0842c7.jpg

Revell1969COPOCamaroZL1c_zpsb30d387b.jpg

Revell1969COPOCamaro4_zps39db102f.jpg

Revell1969COPOCamaro6_zps00bd333c.jpg

Edited by RandyB.

Share this post


Link to post
Share on other sites

Posted · Report post

Other than the broken post, very nice.

Share this post


Link to post
Share on other sites

Posted · Report post

Looks sweet... :)

Share this post


Link to post
Share on other sites

Posted · Report post

Very nice!Great paint work too...

Share this post


Link to post
Share on other sites

Posted · Report post

Nice looking model, Randy.

And yes, things happen and I've learned to live with stuff like that. Most of my models have some (for me) glaring imperfection on one side - so they get displayed with that side to the wall and I soon forget about it.

Share this post


Link to post
Share on other sites

Posted · Report post

Very sharp model Randy. It has happened to me also. Nice work...

Share this post


Link to post
Share on other sites

Posted · Report post

What fit issues did you have?what could have caused the snapped pillar?I built the kit and everything fit perfectly! 2007_0903Spock0424.jpg

Share this post


Link to post
Share on other sites

Posted · Report post

Nice car Randy !

Share this post


Link to post
Share on other sites

Posted · Report post

Looks good Randy, hugger Orange seems to be a popular colour, that's a few I've seen in this colour now ;)

Share this post


Link to post
Share on other sites

Posted · Report post

Classic car with a classic color! Great job! Did you break the post when you put the body on the chassis?

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Thanks guys. I broke the post trying to fit the interior. For some reason this interior wouldn't fit up in tight enough to the top of the doors. I guess I got a little too aggressive with it. I built the Revell '69 Z/28 and didn't have that problem...not sure why this one was being stubborn. Anyway I got the putty and sandpaper out and managed to get the post looking a little better than the way it looked in the first pic I posted.

Edited by RandyB.

Share this post


Link to post
Share on other sites

Posted · Report post

Beautiful build Randy. Sorry about the A pillar, those types of setbacks happen to all of us from time to time. Looks like you were able to repair it pretty well. A couple weeks ago I finally got to see my first actual 1:1 COPO and man was it loud, but not from the exhaust but rather the colors.....Daytona Yellow with a yellow houndstooth interior. It was eye-searing in the blazing sunshine!

Share this post


Link to post
Share on other sites

Posted · Report post

well done Randy! like it. its nice to see the hugger orange on a model ;)

Share this post


Link to post
Share on other sites

Posted · Report post

Nice.

Share this post


Link to post
Share on other sites

Posted · Report post

great build!!

Share this post


Link to post
Share on other sites

Posted · Report post

nice camaro. very clean build.

Share this post


Link to post
Share on other sites

Posted · Report post

Looks Great!!

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks guys on the great comments. Well I took some better pics of the Camaro today. I fixed the post late last night so I had to take indoor pics under poor lighting conditions. Check out my repaired post taken outside in the sun plus a couple of other angle pics.

Revell1969COPOCamaroZL-1d_zpsb1d89dab.jp

Revell1969COPOCamaroZL-1c_zps9d3f2f0d.jp

Revell1969COPOCamaroZL-1a_zpsf4314c9d.jp

Revell1969COPOCamaroZL-1b_zpsd57e2d2f.jp

Revell1969COPOCamaroZL-1e_zpsd8040b1e.jp

Share this post


Link to post
Share on other sites

Posted · Report post

Looks nice

Share this post


Link to post
Share on other sites

Posted · Report post

Dang Randy , I can't even tell where the post was broken, ifyou wouldn't have said any thing and posted these pics no one would have known ......GREAT build !!!!

Share this post


Link to post
Share on other sites

Posted · Report post

Dang Randy , I can't even tell where the post was broken, ifyou wouldn't have said any thing and posted these pics no one would have known ......GREAT build !!!!

Thanks Roger and Ron. Things like that really bug me and I just couldn't leave it that way. Feeling better now. :)

Share this post


Link to post
Share on other sites

Posted · Report post

The post looks a lot better, great job.

Share this post


Link to post
Share on other sites

Posted · Report post

Nice save.

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Wow!

Your Camaro is really nice, i built this kit last month and i can say it is still a very good kit..

I like this color on the Camaro, it looks natural..

Good job, nevermind that broken post, i can't see it anymore!!

Edited by mikemopar70

Share this post


Link to post
Share on other sites

Posted · Report post

Very NICE job Randy, bummer on the broken post but stuff does happen unfortunately!! :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now